Joomla! Volunteers Portal

Atualizou a versão do Joomla para 3.7.x e começou a ver o erro abaixo no Painel de Controle (administrator)?

 

Erro

Detectamos que seu servidor está usando PHP 5.5.14, que é obsoleto e não recebe mais atualizações oficiais de segurança por seus desenvolvedores. O Projeto Joomla! recomenda atualizar seu site para PHP 5.6 ou posterior que receberá atualizações de segurança, pelo menos até 31.12.18. Por favor, solicite ao provedor de hospedagem para que a versão PHP 5.6 ou posterior seja o padrão para seu site. Se seu host já disponibiliza o PHP 5.6, por favor, habilite-o nos diretórios raiz e 'Administrador' do seu site - normalmente isso pode ser feito através do painel de controle de sua hospedagem, mas é melhor perguntar ao seu provedor se não tiver certeza.
 
Podemos dizer que, nesse momento, isso é mais um warn (aviso) do que um erro. Mas é um aviso sério.
Significa exatamente o que está escrito ali: você precisa atualizar a versão do PHP do seu servidor.
 
1. "Não sei o que é isso"
Solicite o suporte do seu provedor de hospedagem.
 
2. "Meu provedor disse que não pode atualizar o PHP"
Considere urgentemente trocar de provedor.  
 
3. "Por questões contratuais, não posso atualizar meu PHP agora"
Então faça um plano para evoluir a infraestrutura o mais rápido possível. Lembre-se que uma infra desatualizada pode impedir que você versione a aplicação no futuro, o que gera um grave problema: não apenas você deixa de obter as novas funcionalidades do software, como também fica vulnerável em termos de segurança. Já tive uma experiência semelhante com outro software e garanto a você que, ao longo dos anos, torna-se um problema muito difícil de se conseguir resolver. 

 

O Joomla! está dando o alerta, mas ele vale para todos os softwares escritos em PHP. Considere a importância de manter o servidor sempre atualizado, especialmente porque a maior parte das invasões não ocorrem na aplicação (não, não é culpa do Joomla!), mas no próprio servidor. #fikadika 

 

 

 

Joomla! is a trademark of Open Source Matters. This site is not affiliated with or endorsed by the Joomla! Project or its trademark owners.